GPS Not Acquiring Signal


Active member
Jul 3, 2023
Reno, NV
Anyone have the GPS antenna give up? Mine was working fine and now just spins the wheel and says locating. If I go into the GPS satellites it shows many but they are all red and never turn green.

I've checked all connections and all looks good. No damage, no bent pins, nothing. Just quit after a ride on the 14th.

Curious if anyone else has had problems.
Mine did the same thing! Talked to the dealer and was told to check connections, but the entire ride command unit may need replaced. I’ll take it in this week and see what they come up with.
Plot thickens. I check my email this morning and my ride recorded aside from the trip to the trailhead. WTH? So it's obviously getting GPS data, just not displaying it? I dunno, warranty here I come.

Ryan, I have disconnected and reconnected every connection, even antenna, disconnected battery, hard reset, and updated software all with same result. I'm so confused by it.

Thats exactly what was happening to me. The GPS was working, so I went to the plugs... Ugg on the warranty repair, that's a PITA. Good luck..
Mine did the same thing on Saturday. I recently updated to the most current version (August 2023) of ride command (wonder if that was the issue)? I went back to the May 2023 version and presto! Its working again! Not sure but think its the software version that doesnt like the machine.
Mine has been having issues too and was running the most recent update. Re-ran update and now it is fine. Can’t get wife’s 2020 Pro xp to work for the life of me though. Replaced antenna, rolled back to old updates, etc. Will hold off for awhile on replacing her screen as my hunch is it is a software issue not a hardware issue.
Super funky.....

So I contacted my dealer who told me to disconnect and forget all paired devices.

Then a harder reset then holding the Polaris logo button (middle key down) for 5 seconds. For this one you start with machine off, press and hold far left button, and then key on electrical. Goes through like a hard reboot/ reset (see pics).

Did all that and still no GPS (see pics of what the acquiring satellites screen looked like).

Reverted back to May 2023 software and bam, connected. So I am guessing some funky issue with the August 2023 software update that took a while to manifest.

No idea if it was paired devices, hard(er) reset, or May 2023 software rollback but seems to be working again.

So sticking with May 2023 update for now. Will let dealer know so it can be reported to Polaris. Would encourage others to do the same as clearly there are some issues with the August 2023 software.


  • 20240318_174635.jpg
    176.4 KB · Views: 27
  • 20240318_174702.jpg
    189.2 KB · Views: 23
  • 20240318_175041.jpg
    181.3 KB · Views: 23
  • 20240318_175044.jpg
    139.2 KB · Views: 23
  • 20240318_175046.jpg
    164.2 KB · Views: 25
  • 20240318_180005.jpg
    178 KB · Views: 27
Sorry I’m late to the thread but I had this issue on mine as well and have seen it on several other Xpeditions. The fix is really simple, just run the latest update, even if your Ride Command is already on it. It has fixed this particular problem every time.
Sorry I’m late to the thread but I had this issue on mine as well and have seen it on several other Xpeditions. The fix is really simple, just run the latest update, even if your Ride Command is already on it. It has fixed this particular problem every time.
Thanks for that information. After the hard reset I had to update base maps and that took several tries. I moved back to the August 2023 software and the maps seemed to load after that with no problem. Looks like a thumb drive with the latest software is gonna have to travel with me 🤣

For now I'm back up and running!!!
I’ve kept a thumb drive with me so that anyone else that has that problem, I can help out.

Also the update is the same for all 7” 7 button Ride Command ORV machines so I can update RZRs, Generals and Rangers that ride with us. Most people have never updated since they bought their machines 😂
Mine quit working at around 1200 miles, couldn't locate me.
The dealership replaced the entire system under warranty.
When mine did it, I tried everything I could think of for about 2 days. Hard reset,unplugging and replugging all the wires, even chased all the antenna wires trying to see if they were rubbing or shorting anywhere….
I was about 5 minutes from loading it up and hauling it back to the dealer when I decided, what the heck, I’ll just re-run the update! It was already on the latest update, and I used the same file from my thumb drive that I’d originally updated with but for whatever reason, it just started working again 🤷🏻‍♂️
It took about a full minute after the reboot to find the signal but I haven’t had that problem since.
Got a call back from my dealer today. Said Polaris issued a service bulliten for the very issue I encountered. Solution = new Ride Command.
My dealer called me today. Told me Polaris sent a bulletin to update the software to the May 23 update, then check gps functionality and satellite status. See attached

However, when I went to download the software, there was now a March 2024 update. I installed this one first to see if it would fix the issue, and voila! GPS is now working again.

Hope this helps anyone else with similar issues.


  • image_2024-03-28_091401998.png
    34.5 KB · Views: 17
I'm getting a new Ride Command. the original had several issues. It would hang up periodically. It would make a load pop and reboot. Lately all I could play was music off my phone but not get any sound from FM, AM, and Weather.